From WikiTemp, the GBAtemp wiki
(Creating the page)
 
(IOS Base: consistency)
Line 95: Line 95:
 
|-
 
|-
 
| Animal Crossing city folk
 
| Animal Crossing city folk
| IOS 38
+
| IOS base 38
 
| IOS base 38 is required if you want to use the keyboard.
 
| IOS base 38 is required if you want to use the keyboard.
 
|-
 
|-
 
| Call of duty
 
| Call of duty
| IOS 57
+
| IOS base 57
 
| Doesn't work with IOS base 56.
 
| Doesn't work with IOS base 56.
 
|-
 
|-
 
| Guitar hero warriors of rock
 
| Guitar hero warriors of rock
| IOS 56
+
| IOS base 56
 
| IOS base57 just display black screen. [https://gbatemp.net/post/8985633 report 1]
 
| IOS base57 just display black screen. [https://gbatemp.net/post/8985633 report 1]
 
|-
 
|-

Revision as of 08:56, 24 March 2020

Some Wii games will work with many different IOS bases, usually base 56or 57, but some games might require bases which are not installed by default in any guides, such as base 36 or 53, etc.

This compatibility list provides the required base for games which work only with one specific IOS base. If they work correctly with any base, or with both the "common setup" (both 56 & 57), there is no need to list the game here. This list is for games which work only with ONE base (56 OR 57), or another base than these two common ones.


IOS Slots

The Wii has 256 slots. 0 to 199 are reserved for official Nintendo IOS. 200 to 255 are free to use for your needs.

Softmod guides usually force the user to install three different cIOS base in slot 249, 250 and 251.

Historically, it was setup like this:

  • slot 249: base 56
  • slot 250: base 57
  • slot 251: base 58


As more games work fine with base 57, few softmod guides recently (2018-2019) changed the default base in slot 249 to 57.

  • slot 249: base 57
  • slot 250: base 56
  • slot 251: base 58

It's entirely possible that you don't have these three slots in use but only one. That's totally fine. You don't need all three cIOS!


By default, all USBLoaders are set to use ONLY the cIOS located in slot 249.

In that slot, you probably already have either a cIOS based on IOS 56 or based on IOS 57.

If you don't know what your setup is, you can run syscheck app, and look at your report on the three common lines 249, 250, 251.

One line of a Syscheck report looks like this:

249[56] d2x v8 final

or

250[57] d2x v10-alt

- The first number (249,250,etc.) is the slot number.

- The number in the bracket ([56], [57], etc.) it the IOS base, this is what you need want to know.

- The text is the cIOS version. On Wii, v8 final is preferred. on vWii, v10 r52 is preferred (do not install Alternate r53!), on Wii-mini d2xL is in beta stage so be sure to follow new releases and update it regularly.


Using a specific slot

If you need to use a specific cIOS base, you have to understand how the Wii, vWii and Wii-mini are working.

The console loads and uses ONE and only one IOS at a time.

Installing a new IOS is not enough to fix your compatibility problem! You need to set your USB Loader settings to actually USE the IOS slot you want to load for the game which requires it.

USBLoaders let you change that settings either globally (for all your games), or individually (for one specific game only).

You should set your loader to use by default the IOS slot which is based on either IOS56 or IOS57.


  • If your IOS slot 249 contains "base56" that's good!
  • If your IOS slot 249 contains "base57" that's good too!

You don't need to reinstall or swap slots 249 and 250 to get the desired base IOS in the default slot 249, just go to your USBLoader settings to change the IOS slot to use.

Adding a new cIOS

Before adding a new cIOS to your console, you need to check if you don't already have that cIOS version/base installed in one of your existing slots! Run syscheck (see above) if you don't know your setup.

Do not install ALL random cIOS version and base just to cover your needs "just in case one day you need them". Only install new cIOS if you really need it, because your console's internal memory is limited and it's useless to install many IOS at the same time, remember that only ONE is loaded in memory.

If you need a new cIOS, you can replace and overwrite existing slot you don't need anymore. If your slot248 already contains an old version of cIOS, or a cIOS with a base you don't need anymore, just choose that slot number for your new install. It'll replace it and will prevent having useless IOS on your console. If you don't usually need or use your slot 250 or 251, replace them with the needed base ! don't install new IOS in the empty slot 248 if you can replace the unused slot 250. keep your console clean and uncluttered.

cIOS installers

There are a lot of different cIOS installation guides. you can choose the one you want from here:

Or if you know what you are doing, you can find complete packs for both Wii and vWii.

For wii-mini, this is here.

Bonus

If you want to understand what IOS and cIOS are, please look at this guide.


Compatibility list

IOS Base

Title IOS base Comment/refences
Animal Crossing city folk IOS base 38 IOS base 38 is required if you want to use the keyboard.
Call of duty IOS base 57 Doesn't work with IOS base 56.
Guitar hero warriors of rock IOS base 56 IOS base57 just display black screen. report 1
Spongebob boating bash IOS base 53, IOS base 58 Tested on Wii with IOS base53, tested on vWii with IOS base58. Both might work regardless of the console type. base58 is usually already installed in slot 251 by most guides, no need to install base53.
Spyro IOS base 56 The NFC portal accessory works only with base 56. Plug the Portal in USB Port 1!
Rockband 3/rockband lego IOS base 37 tested with the "ion drum kit" and mic : HDD in port 0 and USB HUB for two accessories in port 1 report 1
Rockband lego IOS base 37 tested with the "ion drum kit" and mic : HDD in port 0 and USB HUB for two accessories in port 1 report 1
Sing it/just dance/etc. IOS base 57 Most musical games don't work with base56. Please, make proper tests and add each game properly in this list.