From WikiTemp, the GBAtemp wiki

This page contains general information for 3DS Homebrew developers.

If you have any questions, you can come to GBAtemp's main homebrew development and help thread. It contains shared sources, examples and libraries.

You can find all known resources (hardware registers, syscalls, utilities) to develop your homebrew on 3dbrew.

To develop 3DS homebrew you need a development environment consisting of tools, scripts and libraries which will be detailed below. The sources are compiled to binary using GNU GCC-ARM or devkitPro with devkitARM. The available tools and SDK work on Windows 32/64bit and Linux.

The languages used to write homebrew are C, C++ and occasionally ASM. There are various online tutorials and books available to learn these languages.
Alternatively, you can also write homebrew in Lua by using Lua Player Plus.

Install devkitPro w/ devkitARM[edit]

DevkitPro is an essential set of toolchains for homebrew development.

Windows[edit]

Use the automated-installer. Install in C:\devkitPro\ and it will install all the latest versions of the required programs (you can disable devkitPSP, but be sure to enable libctru in DevkitARM menu). It will create the environment variables automatically.

Linux / Mac OSX[edit]

1) Open a terminal and execute these commands:

wget http://sourceforge.net/projects/devkitpro/files/Automated%20Installer/devkitARMupdate.pl
chmod +x devkitARMupdate.pl
sudo ./devkitARMupdate.pl /opt/devkitPro
echo "export DEVKITPRO=/opt/devkitPro" >> ~/.bashrc
echo "export DEVKITARM=\$DEVKITPRO/devkitARM" >> ~/.bashrc
echo "export PATH=\$PATH:\$DEVKITARM/bin" >> ~/.bashrc
source ~/.bashrc

Install libraries[edit]

You may want to install various libraries/tools if your project requires them.

Compiling sources[edit]

If you simply want to compile a homebrew project without (or after) editing it, you can use the make utility from the command prompt/terminal.

1) Windows: Open a Command Prompt (Run -> cmd); Linux/Mac OSX: Open a Terminal from your applications

2) Navigate to the project directory (change to the correct path)

cd c:\path\to\your\project

3) Run make

make

If you ever want to remove the compiled files, you can use this command:

make clean

This is often needed when re-compiling a project.

Troubleshooting[edit]

It is possible that sometimes your project will not compile. This can have various causes, for example missing libraries. In order to find out the problem, look into the output for the lines that start with "error:"; those will tell you what the problem is. You can ignore the warnings, they do not cause the compilation to fail.

If the output is big, you can filter it:

make | grep error

If you can't figure out what's wrong, feel free to make a post on the forums about it. Make sure to post all of the error output.

Windows Tip: To copy from your command prompt, right click and choose Mark. Then select the text to copy and press the Enter key.

Common errors[edit]

cannot find 3dsx_crt0.o: No such file or directory
In your makefile, find -mfloat-abi=softfp and change it to -mfloat-abi=hard. You shouldn't ever use softfp for 3DS homebrew.
(name) uses VFP register arguments but (name2) does not
Part of your project or the libraries you use were compiled with -mfloat-abi=softfp while other parts were compiled with -mfloat-abi=hard. Make sure to use -mfloat-abi=hard everywhere. You may have to manually recompile the libraries you use, if needed.
(command) is not recognized as an internal or external command...
Your PATH environment variable is not set up correctly. It should contain the msys folder in your devkitPro installation path (eg. C:\devkitPro\msys). Edit your PATH environment variable and make sure it includes this directory. If the command is python, make sure the python install directory (eg. C:\PythonXX, where XX is the version you installed) is in your PATH as well.
unknown field 'rmdir_r' specified in initializer
Your devkitARM is out of date. Rerun the installer or script.
make[1]: *** No rule to make target `/c/Users/***/path/to'. Stop.
Move the project to a folder with no spaces anywhere in its path

SMDH[edit]

Every homebrew application has an smdh file, containing additional information:

  • Icon
  • Name of the application (Short description)
  • Description of the application (Long description)
  • Name of the author (Publisher)

This information is used in The Homebrew Launcher (3DSX), and in the home menu (3DS/CIA).

The icon is a simple 48x48px png file. You can place this png in your project folder (the same folder as your Makefile is in) and name it icon.png. If no icon.png is present, a default icon from the ctrulib folder will be used.

The other data can be set in the Makefile directly:

APP_TITLE        := My Application 
APP_DESCRIPTION  := A description of my app
APP_AUTHOR       := Me

The SMDH file is automatically created when building the project (unless you explicitly set NO_SMDH in the Makefile).

You can also manually build the SMDH using bannertool by steveice10:

bannertool makesmdh -s "My application" -l "A description of my app" -p "Me" -i icon.png -o myapplication.smdh

Editor setup[edit]

This section explains how to set up various editors to edit and compile (existing) homebrew projects. If you want to start a new homebrew project, you should preferably copy an example project and edit the sources.

Note that this section lists only the more advanced editors which have features such as code auto-completion. You can use any text editor to edit the source files and compile as detailed above. You should however use a proper code editor (aka not notepad). Some examples are Notepad++, Sublime Text, vim, and Emacs.

Programmer's Notepad[edit]

The Programmer's Notepad is (optionally) installed by the devkitPro installer.

1) File -> New -> Project
Give it a name and save anywhere.

2) Right click the project -> Add Files
Now navigate to the example you want and add the files from that folder (eg. Makefile, readme.md, ...)

3) Right click the project -> Add Magic Folder
Navigate to the example directory again and add the source folder within. Repeat this for any other folders in the example (if any).

4) You can build the project using Tools -> Make
Make sure the project you want to build is the active project (Right click project -> active project)

Visual Studio 2015 (community)[edit]

When installing Visual Studio, make sure to install the Visual C++ packages!

1) File -> New -> Project From Existing Code...

2) In the dropdown, choose Visual C++ and click Next

3) Under Project file location, navigate to the folder with all sources. Enter a name for the project and click next.

4) Use external build system, Next

5) Build command line:

make

Clean command line:

make clean

Leave the rest blank. Click Finish.

6) Right click project (in the solution explorer) -> properties

7) Under VC++ directories -> General -> Include directories, add the devkitARM and ctrulib include directories (change if needed):

C:\devkitPro\devkitARM\include
C:\devkitPro\libctru\include

Make sure not to remove anything already in the box! You can add any other include folder that the project may need as well. In the end it'll read something like:

C:\devkitPro\devkitARM\include;C:\devkitPro\libctru\include;$(IncludePath)

Click OK

8) (Optional) Right click project -> Add -> Existing Item
Choose the Makefile and any other files you want to add, then click Add. This step isn't required, but allows you to edit the Makefile etc. from the editor.

Alternatively, you can use "Show All Files" under the "Project" menu (on the top) to display all files and folders as they are on the file system.

9) You can now build the project (Right click -> Build)

Eclipse CDT[edit]

Tested with the standalone Eclipse Mars CDT on Linux. Instructions may be slightly different for other cases. Another alternate guide can also be found here.

1) File -> New -> Makefile Project with Existing Code

2) Under Existing Code Location, navigate to the folder containing the code.
You can leave both C and C++ checked, even if the project only contains one.
Under Toolchain for Indexer Settings, choose a valid Toolchain (eg. Linux GCC)

3) Right click the Project in the project explorer and choose properties.

4) Go to C/C++ Build -> Environment.
Here you need to add the DEVKITPRO and DEVKITARM variables, with their correct paths, eg.

Name Value
DEVKITPRO /opt/devkitPro
DEVKITARM /opt/devkitPro/devkitARM

Make sure to change the values to the paths on your system.

5) This step isn't needed to build, but it will make Eclipse recognize the external libraries when editing code. Go to C/C++ General -> Paths & Symbols -> Includes
Under "GNU C" (or "GNU C++", or both, depending on what files your project has), add the following include directories:

/opt/devkitPro/devkitARM/include
/opt/devkitPro/libctru/include

Again, change the paths if needed. When finished, click OK.

6) You can now build the project. Right click project -> Build project

Code::Blocks[edit]

This premade project can be used as a base https://github.com/TricksterGuy/3ds-template

1) Open the project within Code::Blocks
2) Choose File > Save project as template, and choose a name for the template
3) When creating a new project, choose File > New > From template...
4) In the dialog select the template you created in 2)
5) Choose a directory to put the project
6) To build the 3dsx file choose target 3dsx and click the build (gear) button
7) To build and run your homebrew in citra choose the citra target and hit the build button (only works if citra is installed and in your PATH).

3dsx homebrew[edit]

Homebrew in this format is the most common, and can be played with ninjhax/ironhax/tubehax. No additional steps have to be taken to create this kind of homebrew; it is the default format produced when using make.

The ctrulib folder contains homebrew examples: https://github.com/smealum/ctrulib/tree/master/examples

3ds/cia homebrew[edit]

If you don't need Kernel access, prefer developing homebrew in 3dsx format.

After building the project (see above), you should have an .elf file. You can convert this into a .3ds/.cia file with makerom:

  • Download makerom (and compile it with make if needed)
  • Add the folder where you placed the makerom executable to your PATH environment variable

To create a .3ds or .cia file, you need some additional files in your project:

  • An RSF file - Contains various info such as permissions etc. (TODO: Make guide on how to create these)
  • An icon.bin - The icon and information for the home menu. This is equivalent to the compiled SMDH file, so you can just use that one.
  • A banner.bin - The banner for the top screen

You should preferably put them in your project folder (or a subfolder).

[edit]

Homebrew in 3DS or CIA format requires a banner, which appears on the top screen in the Home menu.

The banner consists of an image and an audio file. The image should be a 256x128px png file. This image may contain transparent parts. The audio file is a 16bit wav file.

You can create the banner.bin using bannertool by Steveice10:

bannertool makebanner -i banner.png -a banner.wav -o banner.bin

Convert .elf to .3ds[edit]

Run the following commands:

arm-none-eabi-strip [ELF file]
makerom -f cci -o [Destination .3ds file] -rsf [RSF file] -target d -exefslogo -elf [ELF file] -icon [icon file] -banner [banner file]

For example:

arm-none-eabi-strip myproject.elf
makerom -f cci -o myproject.3ds -rsf gw_workaround.rsf -target d -exefslogo -elf myproject.elf -icon myproject.smdh -banner banner.bin

Please note that the first command will alter the ELF file, so you may want to back it up first.

Convert .elf to .cia[edit]

CIA files are generic data containers that can be installed on a 3DS. In order to do this you need to have a 3DS below 9.2.

The process of building a CIA is similar to building a .3DS file:

arm-none-eabi-strip myproject.elf
makerom -f cia -o myproject.cia -rsf cia.rsf -target t -exefslogo -elf myproject.elf -icon myproject.smdh -banner banner.bin

Note that the used RSF file is not the same one as the one used for building .3DS files.

Releasing[edit]

When you are ready to release your homebrew application, create a new thread in the Homebrew Development section. In this thread, you can describe your project.

Make sure to attach (or link to an uploaded version of) the relevant files for your homebrew. This will usually be the 3DSX and SMDH files that have been compiled. You can also include the ELF file, which will allow people to repack it with makerom to a 3DS (and CIA) file. The ELF file can also be used on 3DS Emulators (currently two available: Citra and 3DMoo).

If your project is open source, you can upload the code to GitHub. Alternatively, you can simply provide the source as a separate download, or include it with the compiled files.

Using git[edit]

git is a distributed version control system. This allows you to put your code into a repository, which can then be shared with others. The main advantage is that you can keep track of your (and others') changes and even revert them if needed.

You can find instructions on the git website on how to install git on your system.

After git is installed on your system, you need to setup your username and email address. This allows git to identify who made the changes. If you have a GitHub account, use the same username and email as there!

Open a command prompt (Windows) or Terminal (Linux/OSX) and use the following commands:

git config --global user.name "yournamehere"
git config --global user.email "youremail@address.here"

Getting started[edit]

1) If you have not yet done so, create a file named README.md in your project folder. You can use this file to add a description and information of your project. This description will be shown when people view your repository on GitHub. You can use markdown to add formatting such as bold and headings.

2) Open a command prompt (Windows) or Terminal (Linux/OSX).

3) Navigate to your project folder

cd c:/path/to/your/project

4) Initialize it as a git repository

git init

5) Add your existing code to the repository (note: the . is part of the command)

git add .

6) Do the initial commit

git commit -m "Initial commit"

Committing[edit]

When you make changes to your code, they need to be committed in order to "save" them to your git repository. When and how often you commit is up to you, but try to do at most one major change per commit.

1) Make the repository aware of your changes

git add -A

2) Add them to a commit

git commit -m "Message of your commit (eg. describe your changes)"

Add your project to GitHub[edit]

GitHub is a popular host for online git repositories.

1) Create a GitHub repository.
Make sure to name the repository after your project and optionally give it a description. Make sure the checkbox to create a README is not checked. The .gitignore and license should also be set to None

2) Open a command prompt (Windows) or Terminal (Linux/OSX) and navigate to your project folder.

3) Add GitHub as a remote host (change the URL):

git remote add origin https://github.com/yourname/yourrepository.git

4) From now on, you can push your changes to GitHub with the following command:

git push origin master

This pushes the master branch to the remote called origin, which we setup as GitHub.

You don't have to push after every commit, but your changes will only show up on GitHub after you push.

Tags[edit]

Tags are a way on git to mark specific commits as special. For example, you could use them to track your major releases.

1) Create the tag

git tag -a tagname -m "description here"

For example:

git tag -a v1.0 -m "My first release!"

To tag an older commit, specify the sha1 hash of the commit:

git tag -a tagname sha1 -m "description here"

2) If you are using GitHub, you must manually push the tag:

git push origin tagname