From WikiTemp, the GBAtemp wiki
m
 
(63 intermediate revisions by 11 users not shown)
Line 1: Line 1:
 +
<includeonly>=='''Updating the AK2i Bootloader'''==</includeonly> <!-- Logan this will not break readers. It gets included into page main article under a level 2 heading -->
 +
 
[[Image:TKS ak2i-4.png|AK2i|right]]
 
[[Image:TKS ak2i-4.png|AK2i|right]]
  
<noinclude>On July 30, 2009 Nintendo released firmware version 1.4 for the DSi, the first firmware version to block flashcarts. While the update is optional, you must install the firmware update if you wish to use the DSi Browser or DSi Shop (~DSi Ware). The [[Acekard 2|Acekard 2i]] features an updatable firmware of it's own to protect against such measures by Nintendo. It took only two weeks for a workaround to be released for the Acekard, in the case of the Acekard it identifies itself to the DSi as the Danny Phantom retail cartridge.  
+
'''Currently Supported:'''
 +
* AK2i HWID 44 - DSi v1.4.3/3DS v2.1
 +
* AK2i HWID 81 - DSi v1.4.4/3DS v4.3
  
This workaround comes in the form of a downloadable firmware update which updates the Acekard's internal bootloader. You must perform this update for your Acekard 2i to work on a DSi or DSi XL firmware version 1.4, if you don't update your Acekard's firmware will get the following error message when you attempt to boot:
+
On July 30, 2009 Nintendo released the first of 7 (1.4, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.4.6c) firmware revisions for the DSi. Each revision claimed to add background fixes to improve performance while secretly removing Flash Kit functionality. While each update has been optional, you must install the firmware update if you wish to use the DSi Browser or DSi Shop (IE: purchase/download DSi-Ware). Since the release of the 3DS, Nintendo has once again released firmware revisions (2.0.0-2, 2.1.0-3, 2.1.0-4, 3.0.0-6, 4.0.0-7, 4.1.0-8, 4.2.0-9, 4.3.0-10, 4.4.0-10, 4.5.0-10, 5.0.0-11, 5.1.0-11, 6.0.0-11, 6.1.0-11, 7.0.0-13, 7.1.0-14, 7.1.0-15, 7.1.0-16, 7.2.0-17) which bundle Flash Kit blocking among legitimate software updates. Updating, blocking, and re-flashing are inevitable processes of this hobby, thankfully the Acekard 2i continues to function on the DSi v1.4.4 and lower and on the 3DS v4.3 and lower.
  
An error has occurred. Press and hold the Power Button to turn the system off. Please see the Nintendo DSi Operations Manual for help troubleshooting.
+
Team Acekard uses an older “generation 2” Flash Kit design, which is currently not the most ideal hardware for DSi/3DS bootloader exploits. The flashable bootloader of the 2i is not unlike “generation 3” Flash Kits, but requires actual ROM data to circumvent the DSi icon check and secondary data response check. More modern “generation 3” Flash Kit designs (SCDS2, iEVO, iSmart MM) require only an actual ROM icon to bypass the first check and spoof the secondary check with an updatable data file. Acekard’s older exploit method has forced users to wait for fully functional ROM data updates, which are pulled from a limited pool of known exploitable files. For the most part, this older method has worked, that was until users began to notice the differences between the AK2i HWID 44 and 81 Flash Kits. The HWID 44 PCB uses an older design with less bootloader space, which can not be as easily updated. Currently there is no AK2i HWID 44 DSi v1.4.3+ firmware solution nor is there a solution for the 3DS v2.1+ firmware updates.
  
It is not possible to downgrade the DSi's firmware at this time.
+
The 3DS firmware v4.4.0-10 added a new feature which blocked Flash Kits based on their save IC. Many kits have a proper save IC but this information is burned into an area of the chip which is not rewritable by the end-consumer. These kits were unable to release an update, and so far it appears that the AK2i is among them. As a result of the 3DS update almost all Flash Kits have been permanently blocked. Be advised that the AK2i HWID 81 Flash Kit can not operate on a 3DS running any firmware revision after 4.3.0-10.
  
</noinclude>
+
When an AK2i does not contain the proper update the following error message will be displayed when attempting to boot the 2i:
  
<noinclude>==Before you begin==</noinclude>
+
An error has occurred. Press and hold the Power Button to turn the system off. Please see the Nintendo DSi Operations Manual for help troubleshooting.
<includeonly>==Updating to 1.4==</includeonly>
+
  
The firmware update can only be performed using a DS Phat/ DS Lite or a DSi with FirmWare version =< 1.3, there is no way round this. All recent DSi & DSi XL consoles will come preinstalled with firmware 1.4. If you don't have access to a DS Phat/ DS Lite or a DSi with FirmWare =< 1.3 you *must* purchase your Acekard 2 from a retailer such as 0ShippingZone or LeetMod (charge an additional $1) who will update the cart to 1.4 before shipping.
+
Users, who wish to purchase DSi-Ware/eShop files, transfer DSi-Ware, or use the Web browser, should upgrade their system firmware knowing that it can never be downgraded. While the Public DSi-key was found it only allows for the decryption of things like DSi-Ware. Until access to the private key or a fully functionally DSi exploit is found, a DSi firmware upgrade is permanent.
  
Even if you intend to use your AK2i with a DS Lite, you should still consider updating your Acekard's firmware incase your DSL breaks and you later replace it with a DSi. If you have your DSi on FW =< 1.3 you should consider updating your Acekard too, incase someone else unknowingly updates your DSi to firmware 1.4.
+
<noinclude>__TOC__</noinclude>
 +
<noinclude>=='''Before you begin'''==</noinclude>
 +
<includeonly>==='''Before you begin'''===</includeonly> <!-- Logan this will not break readers. It gets included into page main article under a level 2 heading -->
  
After updating the Acekard will appear in the DSi menu as Danny Phantom, on the DS Phat/ DS Lite it will still appear as Acekard.
+
The AK2i bootloader update can only be performed using a DS Phat/DS Lite, or by using a DSi/3DS with a firmware version less than the AK2i bootloader exploit to be applied. The firmware update is an .NDS file and must be run from a compatible Flash Kit on one of the 4 previously mentioned systems. If you can not boot your Flash Kit then you can not run the AK2i bootloader update file. As there is no way to flash the bootloader update to the AK2i with out a DS system, the AK2i must be updated before the system firmware. However, as DS Phat and DS Lite systems do not have upgradable firmware, users who upgrade their DSi before upgrading their AK2i, can always reflash the AK2i bootloader using one of these two older systems.
<includeonly>===Before you begin===</includeonly>
+
Updating the firmware on any device comes with a degree of risk, the Acekard is no exception to this. If an error or interuption occurs during the flashing process, it may leave your Acekard in an inoperable state (bricked). While this is highly unlikely, it's something you should be aware of before flashing. There are several things you can do to minimize the risk of bricking your cart:
+
  
* Ensure the battery on your DS is fully charged and plugged into the mains charger.
+
As new DS systems are built for retail, the most recent firmware update is often applied. Users should keep this in mind when purchasing a new DSi or 3DS. If the user does not have access to a DS Phat or DS Lite then they are advised to purchase a fully updated AK2i from a respected reseller. For more information on resellers check out GBAtemp’s Flash Kit reseller comparison Web site, [http://shoptemp.com/ ShopTemp]
  
* Have a verified working install of [[AKAIO]] and a MicroSD card formatted with the Panasonic MicroSD formatter.
+
After updating, the Acekard will appear in the firmware menu using an actual game icon:
  
* Familiarise yourself with the AKAIO interface.
+
* [[Image:01_ak2i_bootloader_wiki_df_icon.gif‎|danny_pantom_icon]] Danny Phantom - Urban Jungle (DSi v1.4.0)
 +
* [[Image:02_ak2i_bootloader_wiki_ar_icon.gif‎|alex_rider_strombreaker_icon]] Alex Rider: Stormbreaker (DSi v1.4.1)
 +
* [[Image:03_ak2i_bootloader_wiki_ar_icon.gif‎|atama_de_do_koten_kotenko_icon]] Atama de Do! Koten Kotenko DORASU (3DS v1.0.0-0)
 +
* [[Image:04_ak2i_bootloader_wiki_ar_icon.gif‎|chessmaster_the_art_of_lerning_icon]] Chessmaster - The Art of Learning (DSi v1.4.2 & 3DS 2.0.0-2)
 +
* [[Image:05_ak2i_bootloader_wiki_hkpss_icon.gif‎|hello_kitty_no_panda_sport_stadium_icon]] Hello Kitty no Panda Sport Stadium DORASU (DSi v1.4.3 & 3DS 2.1.0-3/2.1.0-4)
 +
* [[Image:06_ak2i_bootloader_wiki_conpc_icon.gif‎|chronicles_of_narnia_prince_caspian_icon]] Chronicles of Narnia - Prince Caspian (3DS 3.0.0-6)
 +
* [[Image:07_ak2i_bootloader_wiki_dldb_icon.gif|deep_labryinth_digital_bros_icon]] Deep Labyrinth - Digital Bros (DSi v1.4.4 & 3DS 4.0.0-7/4.1.0-8)
 +
* [[Image:08_ak2i_bootloader_wiki_dldb_icon.gif|rafa_nadal_tennis_icon]] Rafa Nadal Tennis (3DS 4.2.0-9)
 +
* [[Image:Ak2i_Pippa_Funnell_4.3.0_update_icon.png|pippa_funnell_icon]] Pippa Funnell (3DS 4.3.0-10)
  
* Copy the firmware update files from the MicroSD card to another device, if sucessfull this ensures the files on your MicroSD card are 100% readable.
+
It is important to understand that the bootloader update is backwards compatible with older firmware revisions. If you install the latest 3DS bootloader, you will also be able to boot that AK2i on DSi systems up to v1.4.4. Meaning that the latest 3DS exploit will also function on older DSi firmware releases. The same can be said for the DSi system as well, Deep Labyrinth - Digital Bros will boot on DSi systems with firmware v1.4.0 to v1.4.4.
 +
 
 +
As the icon is a key feature to circumventing the first check, the icons which change with each bootloader update can not be altered and attempting to do so would render the card unusable and unbootable.
 +
<includeonly>===Before you begin===</includeonly>
 +
Updating the firmware on any device comes with a degree of risk, the Acekard 2i is no exception to this. If an error or interruption occurs during the flashing process, it may leave your AK2i in an inoperable state (bricked). While this is highly unlikely, it's something you should be aware of before flashing. There are several things you can do to minimize the risk of bricking your cart:
  
 +
* Ensure the battery on your system is fully charged
 +
* Ensure that your system is using the AC adapter (charger) and that it is plugged-in.
 +
* Use a verified working install of [[AKAIO]] on a microSD card properly formatted with the [http://filetrip.net/file.php?id=25981 Panasonic formatter].
 +
: If [[AKAIO]] fails to work then try changing the Homebrew Soft-reset Hooking method.
 +
: If [[AKAIO]] continues to fail to work then run the update using the [http://filetrip.net/nds-downloads/flashcart-files/download-acekard-2-423-menu-f18392.html Acekard official kernel v4.23]
 +
* Familiarize yourself with the AKAIO interface.
 +
* Try to copy the firmware update files from the microSD card to another device, if successful this should mean that your microSD card is 100% readable.
  
In a worst case scenario it is possible to unbrick an Acekard which has been previously bricked by the flashing procedure, but you will require a DS Phat or DS Lite and another flashcart in order to do so.
+
In a worst case scenario it is possible to un-brick an Acekard 2i, which has been previously bricked, by re-flashing the bootloader. If you only own a DSi or 3DS that has been updated, re-flashing the bootloader will require a DS Phat or DS Lite and a second Flash Kit. The second Flash Kit will be used to run the multi-kit bootloader update, once executed the user will swap in the bricked AK2i and re-flash the bootloader.
  
 
<noinclude>==Downloading the update==</noinclude>
 
<noinclude>==Downloading the update==</noinclude>
 
<includeonly>===Downloading the update===</includeonly>
 
<includeonly>===Downloading the update===</includeonly>
  
You can download the update from http://www.mediafire.com/?n4nm0i5dmtm , extract the downloaded file to the root directory of your MicroSD card. Upon extraction you should have two files, ''ak2ifw_update_14_DSi_new.nds'' and ''ak2ifw_update_14_DSL_new.nds''.  
+
Official update releases should always be hosted at [http://www.acekard.com Acekard’s Web site]. The most current update can be found in the [[#External Links|links]] section below. Download the archive file to your computer and extract its contents.  
  
Many people believe that ''ak2ifw_update_14_DSi_new.nds'' is to be used on the DSi and ''ak2ifw_update_14_DSL_new.nds'' is to be used on the DS Lite, this isn't the case. ''ak2ifw_update_14_DSi_new.nds'' is used to update a single cart, and can be used on the DS Lite, DS Phat and DSi FW =< 1.3. In most cases this is the file you should use because there's less chance of anything going wrong. ''ak2ifw_update_14_DSL_new.nds'' is used to update multiple carts and also unbrick an Acekard previously bricked by either update. This file only runs on the DS Lite or DS Phat.
+
Upon extraction you should have two files:
 +
* '''ak2ifw_update_3ds43_dsi144_onDSi_DSXL_3DS.nds'''
 +
* '''ak2ifw_update_3ds43_dsi144_onDSL.nds'''  
  
There is an older version of the update which some guides/ website still reference, you should use the one from here. The older version has problems updating some carts, specifically some cards will sit at 0% progress on the flashing screen. Some sites (gamekool) will tell you to use the R4i Ultra update instead, this is no longer necessary. The updated tool addressed this issue.
+
Please note that Acekard may change the names of these files with future bootloader revisions.
  
<span style="color:#CC0000;">The latest version of the firmware update can always be found @ http://gbatemp.net/index.php?showtopic=174523 </span>
+
The DSL update file has always retained a multi-kit update function, which allows for more than 1 Flash Kit to be flashed before being forced to power cycle the system. Acekard currently advises users to use the “onDSi” update with the DSi/3DS and the “onDSL” update with the DS Phat/DS Lite. However, some users have reported that either file can be run on either system. While this information has never been officially confirmed, it may be possible to make use of both files on the same system. If you are updating a single Flash Kit then, you can try the “onDSi” file. If you are updating more than one Flash Kit or un-bricking an AK2i by using another Flash Kit, you can try the “onDSL” file.  
  
 
<noinclude>==Updating a single cart==</noinclude>
 
<noinclude>==Updating a single cart==</noinclude>
 
<includeonly>===Updating a single cart===</includeonly>
 
<includeonly>===Updating a single cart===</includeonly>
  
This can be perfromed using a DS Phat/ DS Lite/ DSi <= FW 1.4
+
'''This should only be performed using a DS Phat/DSLite or a DSi/3DS running an older firmware than the one you are updating for.'''
 
+
Boot your Acekard and run ''ak2ifw_update_14_DSi_new.nds''
+
 
+
It takes you straight to the firmware update screen
+
  
 +
Boot your Acekard and run '''ak2ifw_update_3ds43_dsi144_onDSi_DSXL_3DS.nds''', which will take you straight to the firmware update screen:
  
 
[[Image:TKS IMG 3122.JPG]]
 
[[Image:TKS IMG 3122.JPG]]
  
  
Press (start), after the update is complete it gives you the following message:
+
Press START, after the update is complete it will give you the following message:
 
+
  
 
[[Image:TKS IMG 3121.JPG]]
 
[[Image:TKS IMG 3121.JPG]]
Line 68: Line 88:
 
<includeonly>===Updating Multiple carts===</includeonly>
 
<includeonly>===Updating Multiple carts===</includeonly>
  
This can only be performed using a DS Phat/ DS Lite
+
'''This should only be performed using a DS Phat or DS Lite!'''
  
This is primarly used by retailers or people who are going sell on their Acekard's. It allows you to update multiple Acekards in quick sucession. There is no need to swap memory cards, reboot the NDS or reboot into Acekard/ AKAIO between flashings.
+
This is primarly used by retailers, it allows you to update multiple Acekard Flash Kits in quick succession. There is no need to swap memory cards, reboot the NDS or reboot into AKAIO between flashings. Boot your Acekard and run '''ak2ifw_update_3ds43_dsi144_onDSL.nds'''.  
 
+
Boot your Acekard and run ''ak2ifw_update_14_DSL_new.nds''.  
+
  
 
You will get the following prompt:
 
You will get the following prompt:
 
  
 
[[Image:TKS IMG 3124.JPG]]
 
[[Image:TKS IMG 3124.JPG]]
  
  
Eject your cart and insert the first cart you wish to update. Press (B) and you get:
+
Eject your Flash Kit and insert the first AK2i. You can also reinsert the same card if you wish. Press (B) and you will get:
 
+
  
 
[[Image:TKS IMG 3125.JPG]]
 
[[Image:TKS IMG 3125.JPG]]
  
  
Press (start). Once the update is complete you get the following message:
+
Press START. Once the update is complete you will get the following message:
 
+
  
 
[[Image:TKS IMG 3126.JPG]]
 
[[Image:TKS IMG 3126.JPG]]
  
  
Eject the cart and insert another. Press (start) and it will start flashing immediately, it will give no warnings, prompts or ask for confirmation. Repeat the process for as many carts as you have.
+
Eject the Flash Kit and insert another. Press START and it will start flashing immediately, it won't give warnings, prompts, or ask for confirmation. Repeat the process for as many carts as you have.
  
 
<noinclude>==Unbricking a bricked cart==</noinclude>
 
<noinclude>==Unbricking a bricked cart==</noinclude>
 
<includeonly>===Unbricking a bricked cart===</includeonly>
 
<includeonly>===Unbricking a bricked cart===</includeonly>
  
This can only be performed using a DS Phat/ DS Lite
+
Bricked means a device is as electronically useful as a brick. This could cause your Acekard 2i to not appear in the DS menu, or for the DS to freeze as it displays the Health and Safety screen upon start-up. If your Acekard intermittently appears in the DS Menu, then it will be a contact issue rather than being bricked and you should view the full [[Solving_Acekard_2i_Contact_Issues|Solving Acekard 2i Contact Issue]] WIKI Article for more information.
 +
 
 +
'''This un-bricking process should only be performed using a DS Phat or DS Lite''', and is essentially the same as multi-kit bootloader flashing.
  
Boot your Acekard and run ''ak2ifw_update_14_DSL_new.nds''. This can also be run on any working cart, it doesn't have to be an Acekard because it's not going to update the cart you launch it on. You are just using it to get the update into the DS's memory so you can eject the cart.
+
Boot a working Flash Kit (any Flash Kit) and run '''ak2ifw_update_3ds43_dsi144_onDSL.nds'''.
  
 
You will get the following prompt:
 
You will get the following prompt:
 
  
 
[[Image:TKS IMG 3124.JPG]]
 
[[Image:TKS IMG 3124.JPG]]
Line 108: Line 124:
  
 
Eject your cart and insert the cart you wish to unbrick. Press (B) and you get:
 
Eject your cart and insert the cart you wish to unbrick. Press (B) and you get:
 
  
 
[[Image:TKS IMG 3125.JPG]]
 
[[Image:TKS IMG 3125.JPG]]
  
  
Press (start). Once the update is complete you get the following message:
+
Press START. Once the update is complete you will get the following message:
 
+
  
 
[[Image:TKS IMG 3126.JPG]]
 
[[Image:TKS IMG 3126.JPG]]
  
  
Important: power off now! '''Do NOT press (start)'''.
+
Important: power off now! '''Do NOT press START!'''  
  
<noinclude>==Firmware 1.5+==</noinclude>
+
You may see a longer 8 digit Chip ID, this is from where your Acekard is bricked. Upon a successful unbricking, it should return to normal 0FC2.
<includeonly>===Firmware 1.5+===</includeonly>
+
  
Currently 1.4 is the lastest firmware. If a new firmware version is released, it will be featured on the GBAtemp.net home page. If released, do not update your DSi's firmware until either it's confirmed to work with the Acekard or another work around is found.
+
<noinclude>==Downgrading the Bootloader==</noinclude>
 +
<includeonly>===Downgrading the Bootloader===</includeonly>
  
<noinclude>
+
You can flash an older Acekard Bootloader for a DSi/3DS system running an older firmware. if your card ships with the 1.4.4 update already installed but you wish to have the 1.4.1 update, for example, just follow the unbricking steps above but use the older update file. On 12/6/12 Another World obtained the bootloader update files directly from Team Acekard. These files are now generously hosted on Another World's personal Filetrip archive. Please do not abuse these links and feel free to mirror them as often as possible.
== External Links ==
+
{{Acekard External Links}}
+
{{Acekard External Links | FWUpdate}}
+
----
+
{{User:Tk saturn/a}}
+
{{Template:Acekard}}</noinclude>
+
  
 +
* [http://filetrip.net/dl?yF8KWNNxsk ak2ifw_update_dsi-v1.41]
 +
* [http://filetrip.net/dl?yjPhpJqpGe ak2ifw_update_dsi-v1.42_3ds-v2.0]
 +
* [http://filetrip.net/dl?5MjohNKt6B ak2ifw_update_dsi-v1.43_3ds-v3.0]
 +
* [http://filetrip.net/dl?luL1C1BTg8 ak2ifw_update_dsi-v1.44_3ds-v3.0]
 +
* [http://filetrip.net/dl?u9sFEwls12 ak2ifw_update_dsi-v1.44_3ds-v4.3]
  
 +
<noinclude>== External Links ==
 +
* [http://www.acekard.com/download.php Acekard.com Downloads]
 +
* [http://www.acekard.com/download/ak2/ak2ifw_update_3ds43_dsi144.zip DSi v1.4.4/3DS v4.3 Bootloader Update File]
 +
* [http://filetrip.net/f25981-Panasonic-SD-Formatter-3-0.html Panasonic SD Formatter Version 3.0]
 +
 +
* [http://gbatemp.net/t231412-solving-acekard-contact-issues GBATemp's Acekard Contact Issue Guide by TK_Saturn]
 +
 +
{{Template:Acekard}}</noinclude>
  
 
[[Category:Acekard]]
 
[[Category:Acekard]]

Latest revision as of 18:33, 6 June 2014


AK2i

Currently Supported:

  • AK2i HWID 44 - DSi v1.4.3/3DS v2.1
  • AK2i HWID 81 - DSi v1.4.4/3DS v4.3

On July 30, 2009 Nintendo released the first of 7 (1.4, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.4.6c) firmware revisions for the DSi. Each revision claimed to add background fixes to improve performance while secretly removing Flash Kit functionality. While each update has been optional, you must install the firmware update if you wish to use the DSi Browser or DSi Shop (IE: purchase/download DSi-Ware). Since the release of the 3DS, Nintendo has once again released firmware revisions (2.0.0-2, 2.1.0-3, 2.1.0-4, 3.0.0-6, 4.0.0-7, 4.1.0-8, 4.2.0-9, 4.3.0-10, 4.4.0-10, 4.5.0-10, 5.0.0-11, 5.1.0-11, 6.0.0-11, 6.1.0-11, 7.0.0-13, 7.1.0-14, 7.1.0-15, 7.1.0-16, 7.2.0-17) which bundle Flash Kit blocking among legitimate software updates. Updating, blocking, and re-flashing are inevitable processes of this hobby, thankfully the Acekard 2i continues to function on the DSi v1.4.4 and lower and on the 3DS v4.3 and lower.

Team Acekard uses an older “generation 2” Flash Kit design, which is currently not the most ideal hardware for DSi/3DS bootloader exploits. The flashable bootloader of the 2i is not unlike “generation 3” Flash Kits, but requires actual ROM data to circumvent the DSi icon check and secondary data response check. More modern “generation 3” Flash Kit designs (SCDS2, iEVO, iSmart MM) require only an actual ROM icon to bypass the first check and spoof the secondary check with an updatable data file. Acekard’s older exploit method has forced users to wait for fully functional ROM data updates, which are pulled from a limited pool of known exploitable files. For the most part, this older method has worked, that was until users began to notice the differences between the AK2i HWID 44 and 81 Flash Kits. The HWID 44 PCB uses an older design with less bootloader space, which can not be as easily updated. Currently there is no AK2i HWID 44 DSi v1.4.3+ firmware solution nor is there a solution for the 3DS v2.1+ firmware updates.

The 3DS firmware v4.4.0-10 added a new feature which blocked Flash Kits based on their save IC. Many kits have a proper save IC but this information is burned into an area of the chip which is not rewritable by the end-consumer. These kits were unable to release an update, and so far it appears that the AK2i is among them. As a result of the 3DS update almost all Flash Kits have been permanently blocked. Be advised that the AK2i HWID 81 Flash Kit can not operate on a 3DS running any firmware revision after 4.3.0-10.

When an AK2i does not contain the proper update the following error message will be displayed when attempting to boot the 2i:

An error has occurred. Press and hold the Power Button to turn the system off. Please see the Nintendo DSi Operations Manual for help troubleshooting.

Users, who wish to purchase DSi-Ware/eShop files, transfer DSi-Ware, or use the Web browser, should upgrade their system firmware knowing that it can never be downgraded. While the Public DSi-key was found it only allows for the decryption of things like DSi-Ware. Until access to the private key or a fully functionally DSi exploit is found, a DSi firmware upgrade is permanent.

Before you begin

The AK2i bootloader update can only be performed using a DS Phat/DS Lite, or by using a DSi/3DS with a firmware version less than the AK2i bootloader exploit to be applied. The firmware update is an .NDS file and must be run from a compatible Flash Kit on one of the 4 previously mentioned systems. If you can not boot your Flash Kit then you can not run the AK2i bootloader update file. As there is no way to flash the bootloader update to the AK2i with out a DS system, the AK2i must be updated before the system firmware. However, as DS Phat and DS Lite systems do not have upgradable firmware, users who upgrade their DSi before upgrading their AK2i, can always reflash the AK2i bootloader using one of these two older systems.

As new DS systems are built for retail, the most recent firmware update is often applied. Users should keep this in mind when purchasing a new DSi or 3DS. If the user does not have access to a DS Phat or DS Lite then they are advised to purchase a fully updated AK2i from a respected reseller. For more information on resellers check out GBAtemp’s Flash Kit reseller comparison Web site, ShopTemp

After updating, the Acekard will appear in the firmware menu using an actual game icon:

  • danny_pantom_icon Danny Phantom - Urban Jungle (DSi v1.4.0)
  • alex_rider_strombreaker_icon Alex Rider: Stormbreaker (DSi v1.4.1)
  • atama_de_do_koten_kotenko_icon Atama de Do! Koten Kotenko DORASU (3DS v1.0.0-0)
  • chessmaster_the_art_of_lerning_icon Chessmaster - The Art of Learning (DSi v1.4.2 & 3DS 2.0.0-2)
  • hello_kitty_no_panda_sport_stadium_icon Hello Kitty no Panda Sport Stadium DORASU (DSi v1.4.3 & 3DS 2.1.0-3/2.1.0-4)
  • chronicles_of_narnia_prince_caspian_icon Chronicles of Narnia - Prince Caspian (3DS 3.0.0-6)
  • deep_labryinth_digital_bros_icon Deep Labyrinth - Digital Bros (DSi v1.4.4 & 3DS 4.0.0-7/4.1.0-8)
  • rafa_nadal_tennis_icon Rafa Nadal Tennis (3DS 4.2.0-9)
  • pippa_funnell_icon Pippa Funnell (3DS 4.3.0-10)

It is important to understand that the bootloader update is backwards compatible with older firmware revisions. If you install the latest 3DS bootloader, you will also be able to boot that AK2i on DSi systems up to v1.4.4. Meaning that the latest 3DS exploit will also function on older DSi firmware releases. The same can be said for the DSi system as well, Deep Labyrinth - Digital Bros will boot on DSi systems with firmware v1.4.0 to v1.4.4.

As the icon is a key feature to circumventing the first check, the icons which change with each bootloader update can not be altered and attempting to do so would render the card unusable and unbootable.

Updating the firmware on any device comes with a degree of risk, the Acekard 2i is no exception to this. If an error or interruption occurs during the flashing process, it may leave your AK2i in an inoperable state (bricked). While this is highly unlikely, it's something you should be aware of before flashing. There are several things you can do to minimize the risk of bricking your cart:

  • Ensure the battery on your system is fully charged
  • Ensure that your system is using the AC adapter (charger) and that it is plugged-in.
  • Use a verified working install of AKAIO on a microSD card properly formatted with the Panasonic formatter.
If AKAIO fails to work then try changing the Homebrew Soft-reset Hooking method.
If AKAIO continues to fail to work then run the update using the Acekard official kernel v4.23
  • Familiarize yourself with the AKAIO interface.
  • Try to copy the firmware update files from the microSD card to another device, if successful this should mean that your microSD card is 100% readable.

In a worst case scenario it is possible to un-brick an Acekard 2i, which has been previously bricked, by re-flashing the bootloader. If you only own a DSi or 3DS that has been updated, re-flashing the bootloader will require a DS Phat or DS Lite and a second Flash Kit. The second Flash Kit will be used to run the multi-kit bootloader update, once executed the user will swap in the bricked AK2i and re-flash the bootloader.

Downloading the update

Official update releases should always be hosted at Acekard’s Web site. The most current update can be found in the links section below. Download the archive file to your computer and extract its contents.

Upon extraction you should have two files:

  • ak2ifw_update_3ds43_dsi144_onDSi_DSXL_3DS.nds
  • ak2ifw_update_3ds43_dsi144_onDSL.nds

Please note that Acekard may change the names of these files with future bootloader revisions.

The DSL update file has always retained a multi-kit update function, which allows for more than 1 Flash Kit to be flashed before being forced to power cycle the system. Acekard currently advises users to use the “onDSi” update with the DSi/3DS and the “onDSL” update with the DS Phat/DS Lite. However, some users have reported that either file can be run on either system. While this information has never been officially confirmed, it may be possible to make use of both files on the same system. If you are updating a single Flash Kit then, you can try the “onDSi” file. If you are updating more than one Flash Kit or un-bricking an AK2i by using another Flash Kit, you can try the “onDSL” file.

Updating a single cart

This should only be performed using a DS Phat/DSLite or a DSi/3DS running an older firmware than the one you are updating for.

Boot your Acekard and run ak2ifw_update_3ds43_dsi144_onDSi_DSXL_3DS.nds, which will take you straight to the firmware update screen:

TKS IMG 3122.JPG


Press START, after the update is complete it will give you the following message:

TKS IMG 3121.JPG


The update is complete, you can now power off the console.

Updating Multiple carts

This should only be performed using a DS Phat or DS Lite!

This is primarly used by retailers, it allows you to update multiple Acekard Flash Kits in quick succession. There is no need to swap memory cards, reboot the NDS or reboot into AKAIO between flashings. Boot your Acekard and run ak2ifw_update_3ds43_dsi144_onDSL.nds.

You will get the following prompt:

TKS IMG 3124.JPG


Eject your Flash Kit and insert the first AK2i. You can also reinsert the same card if you wish. Press (B) and you will get:

TKS IMG 3125.JPG


Press START. Once the update is complete you will get the following message:

TKS IMG 3126.JPG


Eject the Flash Kit and insert another. Press START and it will start flashing immediately, it won't give warnings, prompts, or ask for confirmation. Repeat the process for as many carts as you have.

Unbricking a bricked cart

Bricked means a device is as electronically useful as a brick. This could cause your Acekard 2i to not appear in the DS menu, or for the DS to freeze as it displays the Health and Safety screen upon start-up. If your Acekard intermittently appears in the DS Menu, then it will be a contact issue rather than being bricked and you should view the full Solving Acekard 2i Contact Issue WIKI Article for more information.

This un-bricking process should only be performed using a DS Phat or DS Lite, and is essentially the same as multi-kit bootloader flashing.

Boot a working Flash Kit (any Flash Kit) and run ak2ifw_update_3ds43_dsi144_onDSL.nds.

You will get the following prompt:

TKS IMG 3124.JPG


Eject your cart and insert the cart you wish to unbrick. Press (B) and you get:

TKS IMG 3125.JPG


Press START. Once the update is complete you will get the following message:

TKS IMG 3126.JPG


Important: power off now! Do NOT press START!

You may see a longer 8 digit Chip ID, this is from where your Acekard is bricked. Upon a successful unbricking, it should return to normal 0FC2.

Downgrading the Bootloader

You can flash an older Acekard Bootloader for a DSi/3DS system running an older firmware. if your card ships with the 1.4.4 update already installed but you wish to have the 1.4.1 update, for example, just follow the unbricking steps above but use the older update file. On 12/6/12 Another World obtained the bootloader update files directly from Team Acekard. These files are now generously hosted on Another World's personal Filetrip archive. Please do not abuse these links and feel free to mirror them as often as possible.

External Links